Fix the broken HP printer driver installation on Ubuntu 15.04, Linux Mint 17.02 and others

If you are running a recent Linux distribution (for exp. Ubuntu 15.04 or Linux Mint 17.2) and been trying to install Hewlett Packard open source printer drivers, you may have encountered the following error message:

error: /home/monostory/.hplip/ file does not match its checksum. File may have been corrupted or altered

Your installation fails and printer is not functional. This issue is currently seen in various different Linux distros and it’s not limited to the mentioned examples. I just discovered this nasty error after updating my Linux Mint desktop to the “Rafaela” 17.2 release and noticed that it reproduces on my Ubuntu Gnome 15.04 laptop as well.

There are several bug reports about this (here and here) and various workarounds offered, but none of them really hit spot. Luckily the fix is simple, and this is how you do it!

  1. First note the driver version that you need. In my case hplip-3.15.2
  2. Then proceed to the HPLIP website and download the corresponding driver files. Note that there are two files that you need: .run and .asc. Place the files to your home folder.
  3. Now open console and from your home directory start the setup process with the command: hp-setup -i
  4. Run through the install wizard, and when you are asked whether to download the drivers or use local files, choose the local option. It asks you for the path to the driver files, so provide the current folder (home): ./

The wizard should now be able to complete successfully after which your printer is again functional.

I got the same problem with ubuntu 15.04 and now on linux mint 17.02 I’m happy to read about your solution to fix it but it doesn’t work when I try to download or save the .run and .asc files. The download always failed… Can you help me with that please.

Could you be a bit more specific regarding the failure of the download? I just checked the HP website and the files download just fine. Without any more details all I can think of is that your disk is full? Can you download any other files?

This instruction worked for me, thanks! I spent hours trying several other methods (including the “official” method from the hplip web page), most of them involved running the hplip plugin file from the terminal. The result was always the same message of missing plugin. I wonder why this method worked and the others didn’t.

@Ademeion Great - that’s what the instructions are for! If you want to help us out, don’t hesitate to share them forward in social media. Thanks!

I have an old HP 1018 Laserjet, and I am getting the checksum error message even after I downloaded the newest version of HPLIP software. It doesn’t seem to care that’s new because I got the same error message before I downloaded and installed it.
I believe the system is corrupted even in the terminal, because that give me messages I don’t understand like some software needs to be uninstalled, or some other crazy answer see following terminal reply:
“cups is already the newest version.
The following packages were automatically installed and are no longer required:
libgsoap4 libvncserver0
Use ‘apt-get autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 110 not upgraded.” I tried to remove as the terminal message instructs, but with no results.

Does anyone understand this? I have been trying to get any printer to work on this OS for months, Dell or HP printers will not work on this Linux Mint 17.3 Rosa OS, and I know this is a 17.2 thread but it’s the closest I could find to my problem…Thanks

Hello @joeinslw and welcome to the forum.

Unfortunately I did not fully understand the nature of the problem. Couple of pointers.

The following packages were automatically installed and are no longer required:
libgsoap4 libvncserver0
Use 'apt-get autoremove' to remove them.

Now this is not really an error. You just have packages that are no longer needed and can be safely removed. You also seem to have 110 packages waiting to be upgraded.

I am not familiar with the HP 1018 printer, but the HP website says that in addition to the open source driver, a binary plugin is required for this printer. Do you have that in place?

Thanks for the reply, after I posted that problem with my old HP Laserjet 1018 (but still good) I did get a response from a Ubuntu user who had the very same problem, it just would not work on Linux Mint.
He gave me a list of Sudo commands to copy and enter into the Terminal, and when I was done I had to unplug the printer count to five, and re-plug it. Then restart the computer and to my amazement it worked, so now I have at least one working printer.
The HPLIP-3.15.2 and the foozjip didn’t work either, I had them on the hard drive, but this line of terminal commands did.
Thanks for asking.

Please do share or link the solution.

Really love you man
Worked like a charm under ubuntu 16.04, HP laserjet CP1025nw color, through ethernet, HPLIP 3.17.11
this should be in the first place of the google search to solve this.
The problem was the same, doing hp-setup or hp-plugin appeared the “file does not match its checksum. File may have been corrupted or altered” error when trying to download plugins from HP servers automatically (its says ““recomended”” lol) , followed the steps , dl the hplip-plugins-3.17.11 .run and asc and solved everything.
Really thank you man.

In co-operation with - get $10 free credits!