Linx and Lamina 7/8/10" tablet owners thread - drivers included!


#21

I’m using the the Lamina 7, (Lamina T-701) running Windows 10 Fall update with the HP Stream drivers.

Drivers all installed correctly. The reg edit from the old drivers did not work with the HP drivers.

The old drivers didn’t really want to work at all for some reason, never bothered with them. Instead i installed the backuped Windows 8.1 drivers, which worked, but were, shall we say, less than optimal.


#22

Hi,

I have a problem with the Lamina t-701 Tablet.
When I try to boot the tablet it goes on and only shows a black screen.
The lock button works normally, but when I hit it, it shows a black screen again …
I tried to reset, but it didnt help. it’s also charged.

Can someone help me?

Thanks,
Wesley


#23

Thats probably the platform driver. Reinstalling the intel atom z3700 series driver fixed it for me…


#24

Thanks for your reply,

But how do I install those ? I tried to open the boot menu ( Power + volume down ) and nothing happend.
Tried to connect with a laptop but it didnt recognize the tablet. Also tried to boot from usb, again nothing.


#25

@wesleyvanrieke

Did this happen all the sudden, or after a Win 10 upgrade or clean install?

@Doc_152

I am not sure what the difference is here. Personally the installation as documented in this thread, using the older driver pack and the HP Stream 7. Only problem is the awful performance of Realtek Wifi and the Wifi not properly recovering from sleep.

Do you have the Rotation Lock feature in the Notifications tray, indicating that the G-sensor is installed correctly?


#26

All the sudden, it was working normally for 5 minutes, then out of nowhere I saw a black screen.


#27

What an awesome post, thank you so much it’s saved me a load of hassle.

I had one slight issue with the Linx 7, this may help others. I done the fresh 1511 install using the HP drivers. It all went in perfectly except for one little hassle. My touch screen was triggering the wrong part of the screen, basically the diagonal opposite.

I went back to the first posted drivers at the start of this post and installed the GoodixTouchDriver from there. It worked straight away :slight_smile:

Now I have everything all up to date, 1511, the HP drivers and just the old touch driver. The system is flying.

Again. Thank you for making this post and linking/hosting the drivers. I don’t think most people realise how time consuming it is to track down certain system drivers, test them, and then share results.

Really appreciated.

Cheers,
Dave.


#28

@wesleyvanrieke

I have read a lot of Linx/Lamina 7 discussion around the web, and the “black screen” is mentioned every now and then. According to people’s posts, some devices have recovered as suddenly as they died but many have also returned their devices for this reason.

  • Does the light give you a blink when you press the power button?
  • Do you see the BIOS boot logo or absolutely nothing?
  • Connect to a charger for a while and then try POWER + VOL UP for ~10 seconds. Anything?

@David_DEVO_Harry

Thanks - glad I could help! You can return the favor by spreading the word.

I puzzles me why there are various different reported issues by users. You had coordinate issues with touch, many people have orientation/rotation issues. There aren’t really many different ways to do the installation, so where does the delta come from? I always recommend installing drivers from the Device Manager / Update Driver -functionality.


#29

Does the light give you a blink when you press the power button?

  • Yes, it does give a blink.

Do you see the BIOS boot logo or absolutely nothing?

  • Nothing at all.

Connect to a charger for a while and then try POWER + VOL UP for ~10 seconds. Anything?

  • It restarts, but then the black screen appears again.

#30

Hi.

I will be doing some YouTube posts and link to this post for info on the Win 10 upgrade process.

Here’s a simple unboxing of the Linx 7

The slight issue I had with the touch alignment isn’t something I’ve read anywhere else, and no one on this post seems to have suffered it. There will always be slight individual issues, but it was easily sorted using the various drivers you have provided.

As for Linux. It’s not something that I use, so can’t really say anything about it. Although most things I’ve read say the only issue is a lack of internal audio 64 bit support with the BT soc. While this could be an issue for running things like OpenElec. It’s easily got around by using a 32 Bit OS and running Kodi over the top.

Although I can’t wait to see what Intel’s Skylake equivalent of BayTrail is going to be. These mini devices that already run on BT are massively under rated. I’ve been a huge fan of the Atom CPU since it came out and with the modern equivalent/versions being very powerful for what they are, and having great GPUs. I just wish more people would take them more seriously, as most people’s day to day computer usage, Internet, email, video, music, office apps etc. are well covered.

At least great resources like this site help to spread the word.

Cheers,
Dave.


#31

Looks like it also stopped restarting after pressing power for ~20 seconds.


#32

It’s been quiet recently in the Linx world. Actually my unit (Lamina T-701) has been collecting dust for a few weeks, as I eventually got pissed off by the misbehaving WiFi (awful performance, device sleep mode kills it totally). I have actually acquired Win 8.1 with Bing .ISO image and plan to downgrade it at some point of time.

Has there been any updates, drivers or anything special in the Linx/Lamina/Baytrail world that I should be aware of?


#33

Hey, If any of you guys need more space on their 16GB/32GB tablet, like a Linx/Lamina 7/8 (No idea about the 10 storage), then you can download this file, and run it:

http://1drv.ms/1IzTkCl

I made it myself. It’s just a glorified batch file that runs a command that enables CompactOS (a.k.a WIMBoot) to compress the operating system, and give about 2GB more free space.

P.S It only works with Windows 10, and if you think I’m scamming, just scan the file :smile:


#34

Thanks, i updated my linx 7 to windows 10 and my screen rotation wouldn’t work, i followed the steps to install the driver and i got the rotation back, but it was 90 degrees out, i ran the driver and reg again, rebooted and it’s fixed, thank you so much :slight_smile:


#35

Windows 10 already uses a so-called “wimboot 2.0” ( https://blogs.windows.com/windowsexperience/2015/03/16/how-windows-10-achieves-its-compact-footprint/ ), which means it’s enabled on every device by default. Not sure what your undocumented exe is supposed to accomplish on windows 10. Can you post some figures?


#36

Well it gave me extra 2-3GB so you know… If you don’t trust my “undocumented exe”, then don’t use it. All my “undocumented exe” is, is a batch file containing cmd commands from WindowsCentral.com, converted to an executable.


#37

I found the reference, http://www.anandtech.com/show/9676/windows-10-feature-focus-compactos . Post a link with your exe and it’ll make more sense! :slight_smile: Or show source code. You can’t readily trust people on the internet, even if they’re nice… until you know them better. Sorry - it was not meant as an offense to you.


#38

to be honest: I don’t have the source code. All I did was open up the notepad and copy pase from here and from there. I may find the bat file if that is what you want, but I need to repair my PC first. I coded it on there and currently, my bios chip is broken, so I need an replacement.

Edit: But that link you posted is exactly what my exe contains.


#39

@denaxin why did you convert it as .exe if it was originally a .bat script? The .bat format would have allowed people more easily to have a look at what the script actually does. After all, this is a serious operation affecting the operating system, so for security reasons nobody should do it without careful consideration.


#40

I compiled it into an EXE to make it more professional. I don’t force anyone to use it, and if that means anything for anyone, I can grantee that it’s its safe. But never thrust anyone randomly on the internet anyways. I made this script for personal use, so this is only if you want to try it.