Linx and Lamina 7/8/10" tablet owners thread - drivers included!


#62

Hi again. Thank you for your swift answer.
Regarding the WLAN I was told by Captech Sweden to alter the power settings to never go to sleep mode when battery charger is connected, only the screen should go to sleep mode. Charger is connected via an USB-hub with USB-Keyboard. Never have any problems since then with downloading or updating. Or did I misunderstand your definition of Sleep-mode?
Regarding the update proceedures I did try different options. The one that really worked was the clean installation wiping everything out. But neither the cameras nor the rotating sensor worked after that. Tried to download the HP-drivers and installing them messed it up. However, I’ll try again according to your instructions and have a strong feeling it will work this time. Thanks again.


#63

Hi Again
Sorry I did not succed :frowning:

I made an USB-stick with the mediatool from Windows with windows 10 on.
If I go for an update. I always get stuck with the not enough memory problem. Even if I point another drive - a SD-card with 64Gb space- it still needs 4 GB on C:. So I am stuck with the update mode. Seems to me i have to make a clean install.

The partitions of C: looks like this:
Total Free Type
Unit 0 Partition 1: System 100.0MB 53.0MB System
Unit 0 Partition 2: 128.0MB 128MB MSR (reserved)
Unit 0 Partition 3 Windows: 9.8GB 2.6GB Primary
Unit 0 Partition 4:Images 4.5GB 216 MB OEM (reserved)

I also realized that the PORTS are USB3 port. Using hubs with powering and charging the tablet makes it fail to find the USB-stick when rebooting. I have 3 different hubs. 1 USB with powersupply on al the ports- It also have an on-off button for the power - now i think I know why.
And an old USB2 hub with powersupply - same here if powered it wont reboot to the stick.
And lastly the small hub in post no 44:" Additionally, check this little thing out=> http://eu.banggood.com/Wholesale-Warehouse-4-Port-Micro-USB-OTG-Charger-HUB-Cable-For-Tablet-Phone-wp-Uk-975460.html12"
It nows come with a switch that can be set in 3 positions. Choosed “2” since i found the HP7 tablet listed there. However if you have the powersupply connected you´’ll have the same problem as described. If you disconnect the powersupply your keyboard wont work - but setting the switch to 1 will. Believe this could explain a lot of issues regarding rebooting.
The whole thing isn’t easier to explain since I’m using a swedish language pack.
So basically I’m still stuck with windows 8.1 and can’t upgrade.
Any ideas?
Kind regards LarsN


#64

The HUB works like this:
1 - normal OTG USB hub => works during boot
2 - OTG+Charging usb hub => ONLY WORKS IN WINDOWS
3 - not sure what this does

Basically, you will need to charge your tablet to full and switch to mode 1 on the hub.


#65

Hi Again.
Just double checked the HUB in position 1 and 2.
Look at the pictures.
In position 1= no charging. Keyboard works, USB-stick visible in the fileexplorer as ESD-USB(E:)

You also see the content on the Stick:

In position 2: Keyboard do not respond and the USB-stick disappeared.

Last night i realized that the USB-stick DO NOT BOOT! It is not bootable! Even if it has a bootsection as shown in the picture. Contacted Sandisc and they confirmed their sticks are not bootable. And the stick was prepared with the Microsofts mediatool!I took for granted that the disc created with the tool would be bootable. Thats why I’m always stuck when rebooting. I simply always land in the normal update mode downloading the update from Microsoft. Could this be the clue to many of those updating problems that many of us have faced?
A friend told me of a free program called Rufus that make sticks bootable. and hopefully I’ll be able to test this soon.
Thanks again for your help.


#66

About position 2 - it works, but it’s finnicky. Unplug the hub (make sure it’s still plugged into power), switch it to anything else, then back to position 2, and then plug it into the linx/lamina. Make sure that you are doing this while windows is already fully booted up and running, and make sure you have changed the uefi options.

About bootable or not, I noticed sometimes the tablet won’t pickup the boot even if it works and even if it’s properly created and the hub is in position “1”. You might need to drop into the uefi shell and manually boot by selecting the usb (it’s usually fs3: or fs4:) and then navigating to the uefi bootstrap file. If you want I can create a picture guide for you, I’ve done it a few times myself when the boot loader for the linx was being stubborn.

I noticed that sometimes it helps if you go into uefi and then force-turn-off the tablet (by pressing and holding the power button until the tablet’s screen goes off).


#67

BTW, I have never used a powered USB-hub when upgrading or clean installing Linx/Lamina, so it is definitely not mandatory for the process. Charged to 100% you’ll only lose like 20 points during the procedure.


#68

Dear Vulpix Thanks for your patience and I would love to have a picture guide. I already tried the UEFI-shell but still it didn’t boot from the stick because it didnt find it after the restart. Obviously I’ll try it again and will follow your instructions to the letter. But it is fishy that the SANdisc behaves like a Higgins particle. Tried to make a new stick with Microsoft mediatool to a smal Verbatim USB and it always shows up in the driveindex after the reboot.
And to our dear Admin: Regarding the powersupply - you are quite right. A fully charged battery is sufficient to last for the update!


HOW-TO: Complete CloneZilla backup and recovery of your Linx/Lamina/Windows x86 tablet
#69

I’ll make a bit of a comprehensive guide.

I assume your problem was solved with the use of a different usb stick - because the one from sandisk shows up as a fixed drive. You might want to check out this tool: http://www.getusb.info/flip-your-bit-usb-utility-to-make-local-drive/ no guarantees on data safety, you may even kill your usb drive. Still, guide below.

I don’t know if all of the steps are required, maybe the media creation tool is a lot better nowadays - but I remember that sometimes it was necessary to do the “phase A” for windows 7 media creation tool even though it should technically format the entire flash drive - so here goes.

For the guide, the USB stick will be E:\ .

The guide has 3 phases.

A) cleaning of the usbstick (you will lose EVERYTHING on the stick)
B) creating a bootable usb stick using the windows media creation tool
C) booting from the usb using the UEFI shell

Phase A:

  1. On your regular PC, plug in the USB disk

  2. type “cmd” into start, when it comes up, right-click it and press “run as administrator”:

You get into a command prompt.

  1. in the command prompt, type diskpart - it might take some time to open depending on the number of attached disks

  2. once in diskpart shell, type list disk

  3. in the output, locate your USB drive. Generally, you should look at the size and compare it to the size of your usb. It should also be the highest-number disk since you added it last.

  4. select the disk by typing select disk <number> , where the <number> is the number from the list above that corresponds with your USB stick

  5. completely wipe any partition records by typing clean

  6. create a new partition create partition primary

  7. format the partition as NTFS using quick format format fs=ntfs quick

  8. mark the partition as active active

– optional step 10b below –

10b) if the disk does not have a drive letter (you can check it in file explorer now, it should be showing as an empty NTFS drive), assign one by typing assign

– optional step ends –

  1. exit diskpart by typing exit and close the CMD window.
    The entire process can be seen on the below screenshot from my VM:

Phase B:
This is probably something you’re familiar with, so no screenshots.

  1. Get the windows media creation tool for W10:
    http://go.microsoft.com/fwlink/?LinkId=691209

  2. Start it, in the first choice select “Create installation media for another PC”

  3. On the next screen, uncheck “user recommended options for this PC” and select your language, select “Windows 10"” and “32bit” architecture.

  4. On the next screen, select USB flash drive and on the following screen select the flash drive we just cleaned (it should be something like E: (no label) )

  5. Let the media creation tool do its magic

  6. When it finishes, close it and either power off your PC or use the “safe eject” to remove the installation usb stick from your PC.

Phase C:

  1. Plug the USB stick into your hub. Assuming you have the same one as I do, set its position to 1

  2. Plug in your keyboard

  3. Plug the hub into power

  4. Plug the hub into the linx/lamina tablet.

  5. Remove the microSD card from your linx/lamina if you have one inserted (!)

  6. Start your linx/lamina and mash DEL to get into UEFI

  7. Once in uefi, navigate to the last tab called Save & Exit

  8. On this tab, navigate alllllllll the way down to select “Launch EFI Shell from filesystem device”

  1. Once the shell launches, locate the fsX: reference to your usb. You are looking for the first reference to “USB” in the device path. For example, the integrated eMMC disk will always be attached to controller 0 and look something like:
    PciRoot(0x0)/Pci(0x17,0x0)/Ctrl(0x0)/HD(bunch of stuff)
    whereas what you are looking for is something that has USB instead of the Ctrl:
    PciRoot(0x0)/Pci(0x17,0x0)/USB(0x1,0x0)/HD(bunch of stuff)

When you see it, you should find the relevant “fs” name. It’ll be either listed in the first column, or in the “alias” section, depending upon how far the initial list scrolls.

In my case, it was fs3.

  1. Navigate to fs3 by typing fs3: into the EFI shell (note there is no “cd” in this command!)

  2. Navigate to where the EFI bootstrap file is by typing cd efi\boot into the EFI shell (now there is cd! )

  3. bootstrap - press tab to cycle through files in this directory - since there is just one, you should immediately get the bootia32.efi filename in the shell.

Screenshot for the previous 3 steps:

  1. press ENTER and voila, you should be booting from the USB!

Hope this helps. Please excuse the gorilla-style photography; I don’t have a hdmi capture card, ha.

EDIT: Bonus, see my custom boot manager, rEFInd ( http://www.rodsbooks.com/refind/ ) , selecting the option to boot from the media-creation-tool-created USB:


#70

Interesting guide - you are moving on a territory I am not familiar with. Perhaps we should split this to a separate topic? What would be the title?

Is there a reason not doing this using standard Windows partitioning tools, or Gparted?


#71

Hiya!

Not sure which part of the process you’re referring to - I am using standard windows partitioning tools to clean the usb drive before using the regular media creation tool from microsoft.

If you’re referring to rEFInd - that’s just some silly thing I was looking into because I got tired of how the internal linx bootloader sometimes doesn’t see the usb. rEFInd sees it every time, and it was not difficult to ‘inject’ it into the standard linx installation.

rEFInd doesn’t however deal with partitions, so I’m not sure I’m correctly understanding the question. Still, I do think that this should probably be in a separate topic, since this one is pretty long and people could scroll over it as they’re browsing the whole thread, and I think it’s a nice guide which is applicable to most of these hubs and most linx/lamina devices.


#72

Dear Vulpix,
Your guide is excellent and got me al the way to the reboot :slight_smile:
Then comes the question: Upgrade or advanced install (Clean/fresh installation)
According to the post Nr61:" With the update you should not need many drivers. The last time I did it only the automatic screen rotation needed fixing by adding a driver and a .reg file patch.“
I guees it’s Upgrade so of course I choosed the upgrade!
Then the installation starts. After a while it says something like: The computer was started with Windows Install.media. Disconnect the installationmedia and reboot so that windows starts normally. Then reconnect the installationmedia and restart the Upgrade from the desktop…etc”. Doing exactly that and going to the desktop - nothing there that wasn’t there before. If I from here go the the restore options, I can reset from the UEFA shell using the stick created with the mediatool and am able to boot the stick from there. Start windows upgrade and ends at the same point with with my old problem with insuffient memory etc.

So if I am supposed to make a clean install removing al the files keeping nothing I guess I’ll have my old problem back with missing drivers.
So please tell should I make a clean install and what about the drivers needed? Bear in mind my Lamina 7 do not have 32Gb of memory as the new releases has.
Very kind regards
LarsN


#73

Hello @LarsN ,

It seems that you may not have an option but to perform a clean reinstall. I tried checking if it’s possible to delete the recovery partition and free up some space, but since you have a 16gb device, the recovery partition is actually being used for WIMBoot; which means that the recovery image/main wim file is being used not just for recovery but also for normal functionality of the system. Therefore, it is not possible to delete, relocate or otherwise modify this partition (you could delete it from within some kind of linux environment for example, but you would end up with unbootable system!) and thus not possible to free up enough space to be able to install w10 via upgrade.

Therefore, I highly recommend you create an initial backup of your device using Clonezilla (I can create a quick guide on how to do this). With this backup, you’ll be able to “go back” regardless of what happens (I believe @Admin can attest to this ). After you have this backup, follow the installation advice in this thread to perform a clean installation of windows 10. It may take some time to get everything working, but all of the drivers should be available here as well, plus microsoft now has a lot of them on windows update as well, so once you get any kind of connectivity, you should be able to get the rest of the drivers, no problem.


#74

Hi Vulpix,
Thanks for your effort! I would really like to keep trying and to clone my device before trying the clean install again. As I recal that last time I tried it, it worked but no front camera, back camera 90Degrees of ,only fixed orientation and some other features were missing. In order to correct that i downloaded the HP drivers and that was a catastrophy. After that no USB-keyboard response, built in keybord was 180 degrees of. So i had to send back to Captech for a restore back to factory settings - got it back after 5 weeks. And this was the second time!
So a guide to clone with Clonezilla would be appreciated. Could it also show how to reinstall the clone?
Thanks again for yor patience.
Kind regards
LarsN


#75

@LarsN , please check the guide over here: HOW-TO: Complete CloneZilla backup and recovery of your Linx/Lamina/Windows x86 tablet . I posted it as a separate topic so that it wouldn’t lengthen this already-long thread. If you have any questions, feel free to ask!


#76

Dear Vulpix
It’s a pleasure ro read and follow your instructions, so I can testify they are Fool Proof :grin:


#77

Just in case you’re as crazy as me to experiment with this, and just in case there was any doubt, Linx supports 128GB SDXC cards!

Performance is quite okay for bigger files, averaging about 14MB/s write 23MB/s read, so no different from pretty much any of the other sd cards I’ve used before.


#78

Just want to report that the clean install is done.
Now I need drivers since I do not have:
Touchscreen - Nonresponsive screenkeyboard. Only USB-Keyboard
Camera
orientation locked
SD-card reader
maybe more I didn’t realize yet.

I do have WiFi though.
So do I use the drivers in comment 1? I am not sure I dare use the HP7 drivers.
I believe that a new bunch of Linx7drivers were launched november 2015

I also managed to joggle the USB-switch between pos 1 keyboard and USB sticks active and pos 2 charging the battery when it was just installing and working on its own. So I have had it on the whole day without any powershortage. The Hub in comment 44 is working just fine.
In windows the pos 2 allows both keyboard, USB stick and charging :slight_smile:

Kind regards
LarsN


#79

Well, I have had similar success with both drivers, the originals and HP Stream 7. Therefore I don’t see any reason why you shouldn’t. However, I don’t think anyone knows for a fact whether different Linx 7 units have differences in hardware. It is totally possible, especially in this price category.


#80

Dear Admin and Vulpix!
Tanks to you guys and this forum I AM UP AND RUNNING windows 10 on a Lamina7 purchased april 2015 with 16Gb internal storage and SD card of 64Gb where I am able to install Apps and programs. Camera works, screen orientation right after applying the instructions above. I also had a reason to learn al the keyboards shortcuts in order to navigate on the screen with no touch sensibility and without a mouse.This page was a lifesaver: http://windows.microsoft.com/en-us/windows-10/keyboard-shortcuts.
Now I’ll make a clone of the disc before I move on experimenting. :slight_smile:


#81

Hi again.
After installing office 365 and chrome there wasn’t any space left on C: Updates from windows couldn’t download. Uninstalling chrome was enough but it stil installed on C: in spite of the storage settings - new apps to D: (also office 365 installs automatically to C:
Found this workaround on Chrome
forum:
"ds1055 sa:
The only thing I have figured out to kick Chrome to another drive (must-do for me since my SSD and Chrome don’t get along - Waiting for cache all the time) is by way of directory junctions.

Basically, before install (or cut/paste to new directory after install, then run commands) run the following commands:

mklink /J “C:\Users{username}\AppData\Local\Google” “”

mklink /J “C:\Program Files (x86)\Chrome” “”

So, as an example, the commands I ran were:

mklink /J “C:\Users\David\AppData\Local\Google” "F:\Chrome_Data\Appdata"
mklink /J “C:\Program Files (x86)\Chrome” “F:\Chrome_Data\Program Files”

Long story short, when browsing through it LOOKS like you are still on the C: drive, except for a mildly different icon. When the installer runs it doesn’t know the difference. Basically, its like switching the tracks on a rail road. You follow the same path, but once you hit the switch you go in a different direction.

It works flawlessly."

Do you think this would work for the Lamina? The idea is to have as much space as possible on C: to make room for swap-files for the system in order to work more smoothely.
Kind regards
LarsN