Linx and Lamina 7/8/10" tablet owners thread - drivers included!


#82

It’ll work, as long as you use the right path. This is the same as symlinks in linux, I use them myself.


#83

Is it just me or have the recent Windows 10 updates actually improved things?

I haven’t even used my Lamina 7 but I am currently writing this with the tablet. Suddenly the wifi seems to be reliable, even from my mobile phone hotspot, making this useful again.

How is yours?


#84

I never had any issues but my linx is currently gathering dust because without fast user switching, it’s useless to me :frowning: and no, the updates have not done anything to that… but I never had any wifi issues on my linx to begin with, so I can’t say.


#85

Yeah, mine has been very bad, especially with Windows 10:

  • Bad reception even at home, where I have a high performance wifi-router giving plenty of coverage.
  • Terrible with mobile hotspots - I have had to keep Linx less than 0.5 meters away from the source to get a signal.
  • Wifi driver/adapter dies when in sleep mode.

It’s been a few months since I used it, but now I grabbed it and fetched the latest updates. Suddenly it worked Ok at home and even picked up my mobile from several meters away. Weird. As I have bought the HDMI-cable, maybe I can a start using it again as a portable Netflix player.


#86

Personally, since running a VPS for a bit, I wonder if linx could do the same. I’m going to try and get ubuntu 16.04LTS running on one of them to see if they would work as a cheap VPS box. I mean, most of those have the same parameters. 1 core (we get 4 here), 20-30GB SSD, 1GB ram… sounds like linx to me. And the system eats about 150MB of ram when up and running so it sounds like the perfect task. I’ll post back with results, probably in a new topic. (and yes technically not a VPS, but you know what I mean :stuck_out_tongue: )


#87

The Linx / Baytrail should have plenty of horsepower for server tasks. A modern Linux distribution should work, but you need to figure out the UEFI boot issues first. Also display driver, using the internal panel, may be challenge. There are however many stiick-PCs built on Baytrail and some ship with ubuntu.

FYI, if RAM becomes a bottleneck, you can boost that with zRam.


#88

I have a lamina 8’ and I made a fresh instal of win 10 (wipe recovery) and used the drivers for linx8/lamina t-801 ,and it work .Today I made again a fresh instal, everything works fine excepting the touch wich is very inacurate ,I pres somewhere down on the screen and i get the touch working somewhere else.What did I do wrong? , I reinstal the fresh version a few times allready today and I have the same problem with the touch .thank you


#89

I cannot speak for the 801, as I only have the 7" slab, but just to confirm: Which/what touch driver did you use for the clean install?


#90

I use the pack of linx 8 lamina 8 from the top of the page


#91

Yep installed the driver and reg, rebooted and all is good


#92

So, technically, both linx and lamina are no longer w10-supported… as the minimum RAM requirements are now 2GB for both 32 and 64bit systems. Thoughts, @Admin ? :smiley:


#93

Yeah, I read about the updated specs/requirements. This is very typical Microsoft - introduce something (somewhat cool) and then cancel or change it afterwards for whatever reason, pissing of customers. Now that they finally quit their mobile phone business, I suspect a lot of Lumia models will be dropped out the update train as well.

The announcement happened few months prior to the expected Redstone update, aka Anniversary Update. So it might be that devices with 1GB will not receive this update and are limited fo security updates from the Threshold branch?

Keep in mind that Linx/Lamina was never Windows 10 supported by the vendor, along with many other Windows 8 low-end tablets. Another sneaky Microsoft tactic to announce Windows 10 and promote it as a free update and at the same time promote dirt cheap Windows 8 products that are not actually compatible.


#94

Is any of you a member of LinxTablets.co.uk?

It used to be a nice forum, but is now loaded with misbehaving ads, which actually is the very reason I decided to offer the Linx drivers here. Now even key contributors are leaving that site – now I am thinking, we could easily establish some Linx specific forum categories here and whatever is needed, if some of the users and ongoing discussion would herd over here.

NOTE: I will not link to that website due to its unethical advertising practices.


#95

That site is literally the reason I came here - because they wanted a registration or payment to get rid of ads and they kept being incredibly disrupting to browsing if you didn’t! So annoying… I’m all for it (for having a linx section here).


#96

Anyone using Redstone yet (aka Anniversary update) on their Linx?

Since my Linx 7 is mostly collecting dust, I decided to join the Windows Insiders slow ring and received on update to the build 14393.

  • I can confirm that the update works on Lamina/Linx 7.
    • Note that the process will take a very long time.
  • So far I have only spotted minor cosmetic differences here and there - nothing stellar or especially value adding. The animations are slower, which makes the device feel more sluggish.

Anyone else bit the bullet? Any tips what new to look for in the Redstone?

Edit: Here are a couple of fresh stories on what to expect:

  • ZDNet covering the general changes/features and the lengthy update process.
  • Windows Central focuses on the Edge browser.

#97

With the update being so close to release, I’m just going to wait for the official one :slight_smile: Though, ms did change minimum requirements to 2GB of RAM.

I don’t understand how you could ignore the greatest feature and main thing redstone is all about - the linux subsystem for windows. Pretty much full-fledged linux, not running in a VM but sort of reverse-wine-like on windows directly. Go try it out if you haven’t ! :slight_smile:


#98

A command line user interface is hardly the feature for a 7" tablet. But and interesting addition overall. Microsoft’s attempt to lure in web admin people who always use Unix (Linux or Mac). But that’s another topic.


#99

Well, for me it will be as I have some linux tools that will run on the tablet now. I tried installing actual linux on it a few times, but there are always so many things that don’t work (or don’t work properly) that it’s just not worth it; on top of the already-insane process you have to go through to create installation media for a 32-bit uefi 64-bit machine.

But I see what you mean. Unfortunately, my linx has also been collecting dust. I plan on taking it with me as a portable device for travels abroad because if I lose it or if it breaks, no big deal; and it does have a nice battery life.


#100

Evening all, new member here. Just wondering if anyone had satisfactorily resolved this really annoying issue with the charging on the Linx 10. Mine uses power faster than the charger is replacing it. It then goes out and takes several hours to charge enough to restart.


#101

I don’t own a Linx 10, so I do not have first hand experience. There are reports around the web that it really can consume more power than the charger is able to supply. That is not completely surprising, considering the big display size, CPU power, Windows and the charger power output that seems to be 2 Amps. That is not much and rather typical for more powerful cell phone chargers.

You can try saving some energy by disabling Bluetooth, tinkering with WiFi-settings and adjusting screen brightness to a lower value. You should also favor less CPU consuming apps, like the Edge browser rather than Chrome or Firefox.