Remote Desktop Protocol (RDP) on Windows tablets


#1

Hello everyone, I’m basically going nuts here. I need someone else to confirm my theory.

With windows 10 (or maybe even 8.1 but I never really tried…), it is not possible to have a single-session that you can juggle between RDP and regular physical login - but only on the Linx. Or maybe on any small tablet, or maybe even any tablet at all?

To elaborate - I have W10 Pro on my real PC and W10 Home on a virtual machine. On the VM, I use a technically-legal tool called “RDP Wrapper” -> https://github.com/binarymaster/rdpwrap/issues/26 (legality question).

On both, I am able to get the sought behavior, i.e.:

Log in from RDP, open X programs.
Close RDP
Log in from RDP again, X programs are still open and they have been running and doing things as they were, no problem
Close RDP
Log in directly on the machine itself, X programs are still running, the session is all good and until you reboot or log out as a user from windows, it will keep running.

But what I get with Linx 7 (I tried it with both W10 Home using RDP Wrapper and W10 Pro)
Log in from RDP, open X programs
Close RDP
Log in from RDP - either a) get a fresh session or b) get disconnected immediately after logging in.

I tried every possible setting that I could think of to see what I could do about this, but it seems like it must be something based on the fact that it’s a hardware-related special case, because it works just fine on both home and pro on my computer.

I tried doing a complete clean reinstall of the tablet, also verified the system files, nothing. No issues at all. All of the versions are the same; fully updated, LEGAL windows systems in all four cases.

The device was set to not go into sleep mode, no difference. ConnectedStandby was disabled, no difference.

Microsoft support was completely unhelpful, but I never expected much

Can anyone confirm this for me with their linx / lamina? Just enable remote desktop and try logging in, then just close the RDP client (do not log out!) and try logging back in. Leave a note with which system you used and whether or not you were successful.


Linx and Lamina 7/8/10" tablet owners thread - drivers included!
#2

Interesting issue and scenario - never tried that. One thing that comes to my mind is that this could be related to memory management on 1GB RAM hardware?


#3

I tried this (simulated) on my virtual machine. It works, in fact even with 512M of RAM.

The only thing I could think of is something related to wifi powersaving modes - but then again, a laptop that I use doesn’t do this, and if this was wifi powersaving mode, then it would shut down completely and not let me reconnect.

Can you test this on your machine(s) ? Microsoft support was completely unhelpful.


#4

Dammit it is the ram. I was accidentally running a different VM for my tests. Yeah, it is this: http://superuser.com/questions/971271/remote-desktop-windows-10-closing-programs-on-disconnect

That’s incredibly annoying. I’ll try to find a way to make this work, and if I do, I’ll post it here.


#5

I have logged this in technet: https://social.technet.microsoft.com/Forums/en-US/e6e98f5d-8797-4aa8-b15a-0ed855cb1f51/windows-10-rdp-session-causes-logout-immediately-after-closing-rdp-client-for-devices-with-less-than?forum=win10itprogeneral

I am half-tempted to buy the $500 one-incident microsoft pro support, even though it seems like a waste; but it bothers me so much that they just take a feature out without telling anyone.


#6

An update, it’s definitely NOT the ram. I made a clone of the system as a VM, and even in my VM, it worked fine with about 900MB of ram, which is even less than Linx actually has.

The issue lies within something related to fast user switching which does not work. Try it yourself - create a 2nd user and try to switch to it. You will be logged off even though you should simply be switched with all your programs remaining in running state.

Reported as an issue to MS now. https://social.technet.microsoft.com/Forums/en-US/6465436b-cbf8-42f4-8606-a19563189392/cannot-switch-account-without-being-logged-out?forum=win10itprogeneral


#7

So, could it be a combination of low RAM + Fast User Switching? Or does this occur even with plenty of RAM.


#8

I don’t think it’s got to do anything with RAM now, I’ve experimented with ridiculously low amounts.

It is something about the device type or size or hardware. I’m sure of it - something makes windows go “I better disable fast user switching on this thing!” and it will refuse to work. It’s incredibly annoying and nobody knows why. Have you tried to switch users on your device? I’m certain it behaves the same as mine


#9

I have to admit, I feel a bit defeated. The device is otherwise perfect but the way I use it dictates a need for remote desktop connectivity.

Without fast user switching that works, remote desktop will not work the way I need.

Without remote desktop, I cannot realize my dream of having a ~2Watt device powered on 24/7 and only turning my main PC on when some serious work is required.

I’m fairly certain this would behave just fine on windows 7, but it’s impossible to get w7 on this tablet due to x86 uefi. x64 uefi is however not available (I queried linx and they are yet to respond).

Microsoft is ignoring me, and when I queried linx about this behavior, they pointed at MS.

I was considering some kinda silly situation with barebones linux to function as a hypervisor/platform for a windows 7 virtual machine, but I can’t really go ahead with this because I’m sure the performance losses would be too crazy on an already weaksauce platform.

I really don’t know what to do and it feels like such a waste to pay $499 to microsoft just to resolve my issue (and I bet they wouldn’t even do that).

I cannot use linux on my tablet, a lot of the tools that I work with are not compatible with wine.