Running Linux on the Surface Pro 3


Is there info anywhere on how to package something like that for Manjaro?

Edit: I just posted in the Manjaro forums and tagged you in the post. I guess we’ll see if anyone else agrees :slight_smile:


Just an update, looks promising that Manjaro will be patching their kernel versions :slight_smile: Could end up being the first Distro that supports the SP3 fully out-of-the-box, pretty cool!


Yes, I have been eyeballing that thread now. I am actually quite surprised that PhilM was so open towards your proposal. And Photon said he might package it and publish in AUR. That would a very good intermediate solution as well, and enable large scale user testing.

Fantastic. Looks like you made a little breakthrough with this one.


Yeah, I was pretty surprised too, but I think it’s a smart move on Manjaro’s part. From what I’ve seen doing Google searches over the last month or so before switching, people have wanted a solid Linux environment on the Surface line of devices for years… This could potentially drive a huge pool of people to the Manjaro distro :slight_smile:

No someone just needs to fix the longstanding on-screen keyboard not working with the internet browsers problem…


Yeah. That is a huge turn-off and basically eliminates 99% of chances using these devices in tabled mode, without a keyboard. I don’t know whats up with that - apparently browsers don’t trigger appropriate desktop events when the URL text field is enabled.

I wonder does this work in touch enabled Chromebooks? Chrome OS is Linux after all.


Alright folks - this is the big one. This is what we have been waiting for.

###Manjaro 17.02 supports Surface Pro 3

The back story is this - our buddy @slaneaw here did the heavy lifting and applied the missing Type Cover touchpad patch on top of Manjaro’s Linux 4.9 kernel, and it worked. I suggested that this should be proposed for Manjaro kenel maintainers, which he did. The Manjaro project lead and kernel maintainer Philipp Müller welcomed the patch, and it is now integrated to a release.

As of today, the Manjaro 17.02 is at a release candidate phase and the final release is due in no time. The second release candidate now has the Surface Pro 3 Type Cover patches included, along with some SP4 stuff which I can’t personally test as I only have the SP3 in my possession. The RC2 is already quite stable and totally usable as the daily driver. KDE and Xfce candidate images have been released and Gnome edition, along with many other Manjaro variants, should follow soon after the 17.02 stable version is out.

Update 07.03.2017: Manjaro 17.0 stable version has been released: Download

####What we have now working staight off the live media:

  • Hardware keys: Volume up/down, power key :white_check_mark:
  • Touch screen :white_check_mark:
  • Windows Button :white_check_mark:
  • Type Cover keyboard :white_check_mark:
  • Type Cover touchpad, with two finger scrolling :white_check_mark:
    • Using KDE, the mouse emulation needs to be enabled for tap to click functionality.

The KDE is not a bad deskop for the Surface Pro 3, even though it is totally desktop/mouse oriented. You can scale the screen elemets larger for the SP3 ultra-HD display, and strech the panels and widgets to a comportable size. It runs super smooth on the SP3 hardware.

Many may prefer Gnome over KDE though, as it has certain design decisions that are better suited for touch screen usage, including the Onboard virtual keyboard. If you can’t wait for the official Manjaro Gnome 17.02 release, you can download the current stable version 16.10, enable the testing repositories and upgrade the kernel. Switch to Linux kernel 4.9.x using the Manjaro Settings Manager.

Enable testing repository:

sudo pacman-mirrors -g -b testing

Update to RC2 kernel:

sudo pacman -S linux49

And thats it! Happy testing for all Surface Pro 3 owners and kudos to @slaneaw and Manjaro developers.


Manjaro has released the new stable version as 17.0, so a change in version numbering system. The official Xfce and KDE versions are now available - waiting for the Gnome community edition. So no need to use experimental builds anymore.

If you already installed with a release candidate build, it can be upgraded to the stable branch. See Manjaro Wiki for more details. The following command will switch to stable repositories:

 sudo pacman-mirrors -g -b stable


###Some updates to this super popular thread:

  • Manjaro Gnome 17.0.1 is out and it has been promoted to an official version of the dsitribution. This is the obvious choice for Surface users, as Gnome’s design has a level of touch screen friendliness.
  • Ubuntu 17.04 is just about to get released, scheduled for today, U.S. time. It runs the Linux kernel 4.10, featuring a rather good Surface Pro support, which the exception of Type Cover multi-touch. To get it working, you need to upgrade to mainline kernel version 4.11.
    • Download (Should be released on 13th of April 2017)
    • Information regarding the mainline kernel upgrades from here


Hi, i tried to install Manjaro Gnome 17.0.1 (see Post before mine) on my Surface Pro 3. Starting the surface with a bootable USB Stick, grup starts with an error “unknown filesystem”. Google does not help me. Does anyone know how to solve this problem?


I suspect an error in flashing the .ISO image to the USB drive. Try Etcher, it has worked flawlessly for Linux images.


Thank you very much, it solved my problem!


Hi guys,
I’ve been playing around for the last few days now tying to set up some kind of Linux to a friend’s SP3. Pretty much a Win7 user - bound by the software I’m using in my everyday workflow but that’s another story :wink:
First of all - A HUGE THANKS :smiley: since no matter now much I browse around I finally seem to find the answers I need over here.
So I’m glad to report I finally managed to make it behave with the Manjaro GNOME:
touch pad seem to work fine, including the multi touch scrolling tapping and so on, hardware buttons as well.
Thanks to the useful commands above I even scaled down the screen to a great looking size, so - Thanks again!
What I didn’t manage to accomplish however and would very much appreciate your help on is taking a picture from the rear camera - not quite sure if I need an application, patch, a kernel switch or whatever - as I said my skills regarding this are far from intermediate, not mentioning advanced at all :wink:
So please help me out! :smiley:
Some info (hopefully the right one)
Manjaro gnome 17.0.1 , kernel and pretty much the base apps pack coming with the OS
What I managed to do so far was taking a look at myself with an application called Cheers and that’s pretty much it
How can I take a picture from the rear camera and is it actually possible or should I drop this and head for Fedora for example (you said in the very first post both cameras are working there) but then I’ll probably loose the multi-touch support …

Please advise



Great thread! For work reason I need to use Centos, is there any support to get the type cover working for Centos 7?


@Filip_Filyov I can’t say for 100%, but I am somewhat certain that there are no drivers for the rear camera. Higher quality rear cameras are not very common on x86 compatible hardware (laptops, etc.).

@boon CentOS runs a much older kernel. You would need to patch and build your own kernel, unless someone has already done it. Fedora is much closer to mainline Linux kernel development – is it impossible for you to use that?


Hey guys,

Thanks a lot for this thread !! This web site seems to be awesome !!

Did you know if is possible to use Surface pro 3 touchpad (double scroll gesture) with Kali???

This is the only problem i get with this distro at this time ( and wifi driver for sniffing but this is another problem).

If i cant use the touchpad gesture, maybe i will try manjaro (First time i hear this name in my life lol) look like very nice, and reinstall all pentesting tools.

Thank again in advance…

PS: i’m french so i’m so sorry for my poor english…


Here’s my experience…

Surface Pro 3, 128GB SSD.

About 3 months ago I started to play with dual booting my SP3. I was running Windows 10 and Kali Linux. All was great but I allocated the wrong amount of space to Kali and when attempting to correct, I fat fingered the wrong partition and deleted both Kali and Windows. Rather, I formatted the SSD to 0,0,0, and yeah, I have nothing more than a SP3 that can show the BIOS. So to reiterate, I have no OS at all on my surface.
I was able to finally get a linux distro to boot into a live version but cannot get it to install onto the SSD. It keeps failing at loading boot loader and quits the install. I have tried to let it fail, then reboot live, install boot repair and run, but still no success. I have attempted about 7 different kernals and all but Lubuntu seemed to actually fire up. The others won’t. I have checked the .iso’s in virtual box and they work just fine but something fails once loaded to bootable USB.
I have been without the SP3 now for about 1 1/2 months and am at my intelligence limit. I have TERRIBLE internet right now cause i’m overseas, so downloading something like Ubuntu is even difficult and takes about 2 days. I’m stuck with only having 1 single USB flash drive at 4GB so I cannot load any large OS’s. I have a new stick coming in, but mail takes about 6 weeks to arrive.

Please let me know of any suggestions, thoughts, or critiques. I don’t care what OS fires up at this point, as long as I can get it to install onto the SSD, I can at least have a computer till I get back home.




Basically you have all the information you need in this thread already. Regarding Linux, the current best bet is Manjaro, with the desktop of your choice (many prefer Gnome on a Surface). It boots and installs.

But since you seem to have deleted your partitions, I would start by clean installing a Windows 10 to re-create your system partitions. It does take some time though, and I think a 8GB USB-stick is needed, but they cost pennies at any computer store or supermarket. If you are low on bandwidth, then perhaps you can go to an Internet cafe or some other place that offers a higher capacity WiFi.


unfortunately it does not work for me! I tried with Fedora and Ubuntu but the system stay on loading for ages and nothing happened :frowning:


Hi there!
First thanks a lot Admin for this great thread, it’s been so useful.
I’ve been working with linux as a user for 12 years, not in IT but in the VFX industry. I would not concider myself as expert, but I know how to use it.

I just installed F25 on my SP3 and as you stated, installation worked flawlessely and type cover is working as expected. The HDPI is working great too which makes the experience even better! After setting up the welcoming screen with the wifi, the screen instantely freeze and looking at this, it definitely looks like a kernel panic.

I’ve restarted few times and everytime, it freezes after less than a minute after I’ve logged in. After a quick google search I’ve found this [thread] ( that says it is a wifi issue driver.

Did anyone experienced this behavior? if yes, I have a few ideas how to fix it (I think!), but any additional suggestions are more than welcome!
Thanks a lot and have a great day!


Hi all!
I reinstalled the KDE version of Fedora 25 and everything works out the box that’s great!
Thank you