Running Linux on the Surface Pro 3


#61

Which kernel version you are using? Have you tried switching to most recent, using Manjaro settings manager?


#62

I started with 4.9.50 then updated to 4.13.3. Same behavior on both.


#63

Hi!

I’ve been using Linux on several computers, but some years ago now and am now considering installing it on my Surface Pro 3 which should work fine now. However I’ve seen quite a few posts, though older ones, about problems getting dual booting to work. Is this still an issue with the latest versions of Fedora/Ubuntu/Manjaro?
And which would work best out of the box now? I did use Ubuntu back in the day…


#64

Dual booting has been painless for a while now.
Any distro with an up to date kernel is very likely to work flawlessly.
I’m currently running NixOS and everything works out of the box. Had a similar experience with Fedora a while back.


#65

Ubuntu 18.04 LTS is just out, so that should be a solid option.


#66

I did install it and it’s actually worked so well I’ve switched to using it on my surface on a daily basis, with Windows 10 just a backup in case.