Tumbling with openSUSE Tumbleweed


I was on Twitter the other day and raised this question:

Now, don’t get me wrong - openSUSE is a great project. About a year ago they came up with a new strategy of two openSUSE versions: Leap and Tumbleweed. Leap is somewhat of an LTS, with 3 years of support, including two minor versions upgrades. Tumbleweed on the other hand is a bleeding edge rolling distribution. This is a great strategy and all, but why would anyone use openSUSE over Ubuntu or CentOS if one is looking for stability? This dude stepped up:

And he turns out to be the openSUSE chairman. And Mr. Brown is making a big case for openSUSE Tumbleweed on his blog: Why You Should Use Tumbleweed. And he has been repeating this story around the web, promoting Tumbleweed and encouraging people to trust it and their automated testing. Obviously I have ot try myself and see how does it roll.

###Setting up Tumbleweed

openSUSE Tumbleweed is delivered in massive a DVD-sized .ISO file that act as the installation media. It is worth emphasizing that this media does not have a bootable live session, so if you need one before installation then use something else. The installation procedure is rather standard and does not differ very much from any other distribution. Defining the partition setup manually was even more cumbersome than usual.

As the desktop I chose KDE 5.8, but openSUSE ships Gnome (and others) as well. The Plasma 5 is finally getting stable, so I decided to give it another chance:

So the Tumbleweed is now installed and everything is OK so far. I will be making only the smallest amount of changes to the system, as the idea is to find out how steady does the Tumbleweed roll. The initial expression is good. The Plasma 5 desktop eats less than 400MB of RAM after first boot, and the setup runs fine on my aging Thinkpad X301. openSUSE Tumbleweed ships with a very basic Plasma 5 configuration, with only minimal customization.

So this is the day 1 of the long term test. Now we just need more miles and days on this setup. It is worth mentionng that openSUSE still ships without proprietary audio and video codecs, so that is something we need to look into in the very near future. I will be updating this thread regularly and let’s see how it goes.


First issues discovered on the first day:

  • The KDE animations are really smooth, but a bit too slow. Adjusted composer settings for a slightly faster pace, and desktop got messed up / froze partially. Logging out and in again fixed it, and now the animations are faster, but less smooth (tearing).
  • I did the first zypper dup distribution upgrade, with no additional repositories added yet, as there was some 120+ megabytes of updates available. Interestingly these seemed to include Fluendo’s MP3 codec, which apparently is not provided out of the box.
  • I am still unable to play any common media files, such as .MP4 video or .MP3 music. VideoLAN’s repository for Tumbleweed does not work.

This feels like something from mid 2000, having to walk extra mile even for basic multimedia support. I am still clueless whether I should or should not add the Packman repository, which should provide the proprietary yet essential codecs. The instructions and discussion around this topic is unclear, as there are several comments against adding Packman, due to potential update breakage. openSUSE wike pages are full of dead links and so forth…



The annoying KDE Wallet thing is still alive in Plasma 5. Search for “Wallet” to easily disable it.


I could no really make sense out of openSUSE’s lacking documentation, but finally enabled media playback by:

KDE is starting to piss me off. The network manager refuses to save my WiFi WPA2 password. Another weird thing, which should not be KDE or SUSE related but never seen it before, is that Chrome lost all of my active logins, so I had to login again to all websites that require authentication. Such as Twitter, this one, LinkedIN - all the sites I typically keep logged in.


Experienced some hibernate/resume issues yesterday. Laptop was running out of juice and went into weird non-responsive state showing the login screen. I was able to choose to shut down, but apparently laptop had in fact hibernated. Charged and powered on today, but the laptop resumed to login screen and a non-responsive desktop after that. Tumbleweed is bleeding edge and these issues may not be related to openSUSE at all. A bit alarming nevertheless as this is an old Lenovo Thinkpad with Intel chips and as such highly Linux compatible.

The size and number of updates to the Tumbleweed channel are really massive. Again some 400 megabytes today.


Big chunk of updates and again some weird behavior:

  • Rebooted after the updates and got only a mouse cursor on a black screen - no login screen. Rebooted again and it worked.
  • After the second reboot the Internet did not work, while Network Manager did report a successful connection to my wifi. Another reboot and it started working too.

After this odd incidents, the system appears to be working normally.


I am forced to stop this experiment, as I need my test rig for a little Manjaro Linux project.

I used the Tumbleweed for 1.5 months and I am happy to report that it did not break during that short perioid of time. The updates were frequent and massive in size. There were some minor quirks here and there, but nothing major.

I failed to found any compelling reason for using openSUSE, as it is more cumbersome to use than other popular alternatives. Give it a spin if you are interested in rolling, although my personal recommendation for the purpose is Manjaro. Less hassle setting up things for regular daily usage and the benefetis of Arch package management, software and community ecosystem.