Wintel CX-W8 Z3735F Mini PC


#1

Having just found the most helpful post on this site about upgrading the Linx 7 to Windows 10 and the HP drivers, I thought I would share some info on another Bay Trail machine.

This one is the Wintel CX-W8.

While it’s not a tablet, it does share a similar processor with the Linx 7. The W8 is a Mini PC, and when I say Mini, it’s a proper Mini. The machine itself is the exact same size as an Apple TV 3. It has 2GB RAM and a 32GB eMMC drive, 2x USB2, MicroSD, full size HDMI, 100Mb NIC and an audio out. It’s is also available with a 64GB Samsung eMMC.

There are a number of variations around eBay, but you have to be careful. I’ve read that some people have bought them and found that the Win 8.1 install wasn’t permanent. I bought mine from a UK seller for £68, it come with a full 8.1 license that upgraded to 10 Pro. As with all the Z3735 processors, it’s only 32 Bit under Windows and I think 64 Bit under Linux minus the on board audio driver. But 32 Bit Windows isn’t an issue for such a device.

I’ve been using one for a month now under 10, and it’s simply awesome. Just like the Linx, it’s very snappy, maybe a bit snappier, and perfect for day to day computer use and audio/video playback. I use mine as a Plex server and it’s able to live transcode 1080 MP4 files to lower resolutions. It’s also a superb Kodi client, something I will be trying soon with the Linx.

While the 100Mb NIC makes it a bit limited as a data server, although aside from speed it’s a brilliant little server. The LAN speed doesn’t come into it when serving streamed video/audio, as their bitrates are well below the 100Mb of the NIC. Astonishingly, it will play 4K YouTube streams and down convert to 1080, although not via Chrome but surprisingly via Edge. It may even play standard frame rate 4K to a 4K/UHD TV natively, but I don’t have a UHD TV to test this with.

Basically, for anyone into low power drawing Mini PCs, you may want to give it a look.

Cheers,
Dave.


#2

That’s pretty interesting - yes there are a ton of Intel Baytrail based mini PC’s out there: Sticks, dongles, mini PCs and tablets.

I would be interested to know how Linux/Ubuntu runs on that thing. Have you ever tried it?


#3

Hi.

Sorry, I kind of half answered this post in the Linx 7 one.

I’ve not tried Linux or any of its flavours. It’s not that I’ve got anything against it, it’s just that I work in music/video post and all my software has always been Windows based.

I have seen many web posts with many happy Linux users using it, again, aside from the 64 Bit audio issue.

I flashed the bios to 64 bit, something that may even work with the Linx. But Windows wouldn’t go on due to the lack of 64 Bit audio. This audio thing is a historic screw up by Intel, I think it effected the whole BayTrail line, but at least the Z3735F. The SOC was always designed to be 64 Bit, at least with certain OSs.

Here’s a couple of simple YouTube clips, unboxing and size comparison with an Apple TV 3. I’ll be doing some more video tests of this and the Linx 7, will post links when they’re up.

Cheers,
Dave.


#4

What is the “64bit audio” issues that you are referring to - could post a link to the problem description? The reason I am asking is that I was under the impression that reason for the 32bit/64bit dilemma on Baytrail was due to a bug in Microsoft Windows.


#5

The issue isn’t just a problem with Windows. Even if you flash the BIOS with the 64 Bit version, a Windows 64 Bit OS will fail on install. Apparently, even on Linux there is a similar 64 Bit audio problem. Although, on Linux you can get around this by installing a separate audio hardware connection and apply its 64 Bit driver.

I know this problem effects the Z3735F, but I have a feeling it effects other BT versions.

There’s also the issue of not being able to launch certain boot loaders as certain EUFIs won’t work with a 32 Bit firmware and expect to see 64 Bit. Although, as I said earlier, it’s not really a problem for such a inexpensive platform. The main problem I had was not being able to run OpenElec, as the older 32 Bit version didn’t have a corresponding 32 Bit EUFI boot loader, or at least I couldn’t find one. This was sorted out by running Kodi over Windows 32 Bit.

This Google search should show up the issue.

https://www.google.co.uk/search?sclient=tablet-gws&site=&source=hp&q=baytrail+64+bit+audio+driver+problem+z3735+linux&oq=baytrail+64+bit+audio+driver+problem+z3735+linux&gs_l=tablet-gws.3...4498.4498.0.9312.2.2.0.0.0.0.86.150.2.2.0…0…1c.2.64.tablet-gws…2.0.0.0.xRqywlqj9ms

Cheers,
Dave.