Quantum View 10" Tablet


The Quantum view is a great Windows tablet. Released with Windows 8.1. The web site for the tablet ( http://www.quantumsuppliers.com/ in the process of becoming Azulle) shows the device running Windows 10 but when I’ve installed it there are problems with the “sleep” mode on the device. The suppliers have suggested going back to Windows 8.1 but for the moment I’m sticking with Windows 10 and using hibernate instead of sleep, not ideal but a work around.

Has anyone else got one of these devices? Has anyone found a fix to the sleep issue? There appears to be issues with Windows 10 and sleep across a range of hardware. The typical answer is “update the drivers” with varying drivers being the issue dependent on the hardware. I’ve tried updating all the drivers and so far no fix.


The Quantum seems to be one of the many generic Windows 8.1 tablets that are made in China and sold under various brand labels. You could try to search for alternative brands, if they would have better support, or digging deeper to find who is the original manufacturer.

Problems with the sleep mode would suggest issues with the chip set drivers (Intel) or one of the sensors. Does it have a magnetic switch for turning off or waking up the display in the type cover?


After updating display drivers had an issue with the orientation being wrong when turning the screen. Found the answer to this was to set the following registry setting (normal disclaimer about being very careful when making changes to registry)…

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ROOT\SENSOR\0000\Device Parameters\kxfusion]


I too have the Quantum view 10 inch tablet. I purchased it with Windows 8.1 and then upgraded to 10 when it came out. I was disappointed when I began to have the same problems you had with yours. I was unable to find a way to get around this sleep problem.

In the meantime, I had a problem with the power button and so, since the tablet was still under warranty, I called Quantum suppliers and sent them the machine for repair. While I was speaking to the technician I mentioned the sleep problem with Windows 10 to her and her reply was that the power button would no longer work to put the tablet to sleep, but would only serve to turn off the tablet.

I really like Windows 10 and have it on my desktop and my laptop. I would like to have it on the tablet as well so that all my stuff would look and work the same. The sleeping thing bothered me so much that I asked her if she could put Windows 8.1 back on. I had gone over the grace period and could not revert on my own.

Anyway, I have my tablet back with 8.1 but I still would like to upgrade to Windows 10. After using my laptop or the notebook with windows 10, I find it’s more satisfying than using the tablet with Windows 8.1.

If you find a resolution let me know.



Hi guys. Here’s how I overcame the sleep issue on win 10.

I figured it’s the drivers that cause the problem, and that seems to be the case. Whenever I uninstalled the graphics driver the screen would turn on after sleep mode (upon clicking on the power button). So I found an older version of Intel HD Graphics driver (version which seem to work ok with win 10 without the issue. I didn’t notice any obvious glitches, but it’s not a win 10 driver, so it’s surly not ideal.

Also, Windows would automatically download a newer driver regularly (and the sleep problem wold re-appear), so I had to use “wushowhide” to specifically tell Windows not to download graphics updates.

So far I can use win 10 on my tablet for all intents and purposes. Hope it helps.


I tried to download the driver mentioned, but Intel says that it cannot be found.
A website called wingenuine lists it, but it goes to the Intel site which leads to a dead end. Do you think that you can set up a link to that driver? Here’s the site http://theenawingenuine.blogspot.com/2014/04/intel-hd-graphics-driver-for-intel-nuc-1533193540.html