Running Linux on the Surface Pro 3


#41

I suspect an error in flashing the .ISO image to the USB drive. Try Etcher, it has worked flawlessly for Linux images.


#42

Thank you very much, it solved my problem!


#43

Hi guys,
I’ve been playing around for the last few days now tying to set up some kind of Linux to a friend’s SP3. Pretty much a Win7 user - bound by the software I’m using in my everyday workflow but that’s another story :wink:
First of all - A HUGE THANKS :smiley: since no matter now much I browse around I finally seem to find the answers I need over here.
So I’m glad to report I finally managed to make it behave with the Manjaro GNOME:
touch pad seem to work fine, including the multi touch scrolling tapping and so on, hardware buttons as well.
Thanks to the useful commands above I even scaled down the screen to a great looking size, so - Thanks again!
What I didn’t manage to accomplish however and would very much appreciate your help on is taking a picture from the rear camera - not quite sure if I need an application, patch, a kernel switch or whatever - as I said my skills regarding this are far from intermediate, not mentioning advanced at all :wink:
So please help me out! :smiley:
Some info (hopefully the right one)
Manjaro gnome 17.0.1 , kernel 4.9.0.21-1 and pretty much the base apps pack coming with the OS
What I managed to do so far was taking a look at myself with an application called Cheers and that’s pretty much it
How can I take a picture from the rear camera and is it actually possible or should I drop this and head for Fedora for example (you said in the very first post both cameras are working there) but then I’ll probably loose the multi-touch support …

Please advise

Thanks!


#44

Great thread! For work reason I need to use Centos, is there any support to get the type cover working for Centos 7?


#45

@Filip_Filyov I can’t say for 100%, but I am somewhat certain that there are no drivers for the rear camera. Higher quality rear cameras are not very common on x86 compatible hardware (laptops, etc.).

@boon CentOS runs a much older kernel. You would need to patch and build your own kernel, unless someone has already done it. Fedora is much closer to mainline Linux kernel development – is it impossible for you to use that?


#46

Hey guys,

Thanks a lot for this thread !! This web site seems to be awesome !!

Did you know if is possible to use Surface pro 3 touchpad (double scroll gesture) with Kali???

This is the only problem i get with this distro at this time ( and wifi driver for sniffing but this is another problem).

If i cant use the touchpad gesture, maybe i will try manjaro (First time i hear this name in my life lol) look like very nice, and reinstall all pentesting tools.

Thank again in advance…

PS: i’m french so i’m so sorry for my poor english…


#47

Here’s my experience…

Surface Pro 3, 128GB SSD.

About 3 months ago I started to play with dual booting my SP3. I was running Windows 10 and Kali Linux. All was great but I allocated the wrong amount of space to Kali and when attempting to correct, I fat fingered the wrong partition and deleted both Kali and Windows. Rather, I formatted the SSD to 0,0,0, and yeah, I have nothing more than a SP3 that can show the BIOS. So to reiterate, I have no OS at all on my surface.
I was able to finally get a linux distro to boot into a live version but cannot get it to install onto the SSD. It keeps failing at loading boot loader and quits the install. I have tried to let it fail, then reboot live, install boot repair and run, but still no success. I have attempted about 7 different kernals and all but Lubuntu seemed to actually fire up. The others won’t. I have checked the .iso’s in virtual box and they work just fine but something fails once loaded to bootable USB.
I have been without the SP3 now for about 1 1/2 months and am at my intelligence limit. I have TERRIBLE internet right now cause i’m overseas, so downloading something like Ubuntu is even difficult and takes about 2 days. I’m stuck with only having 1 single USB flash drive at 4GB so I cannot load any large OS’s. I have a new stick coming in, but mail takes about 6 weeks to arrive.

Please let me know of any suggestions, thoughts, or critiques. I don’t care what OS fires up at this point, as long as I can get it to install onto the SSD, I can at least have a computer till I get back home.

Thanks!


#48

Ouch.

Basically you have all the information you need in this thread already. Regarding Linux, the current best bet is Manjaro, with the desktop of your choice (many prefer Gnome on a Surface). It boots and installs.

But since you seem to have deleted your partitions, I would start by clean installing a Windows 10 to re-create your system partitions. It does take some time though, and I think a 8GB USB-stick is needed, but they cost pennies at any computer store or supermarket. If you are low on bandwidth, then perhaps you can go to an Internet cafe or some other place that offers a higher capacity WiFi.

https://www.microsoft.com/en-gb/software-download/windows10ISO


#49

unfortunately it does not work for me! I tried with Fedora and Ubuntu but the system stay on loading for ages and nothing happened :frowning:


#50

Hi there!
First thanks a lot Admin for this great thread, it’s been so useful.
I’ve been working with linux as a user for 12 years, not in IT but in the VFX industry. I would not concider myself as expert, but I know how to use it.

I just installed F25 on my SP3 and as you stated, installation worked flawlessely and type cover is working as expected. The HDPI is working great too which makes the experience even better! After setting up the welcoming screen with the wifi, the screen instantely freeze and looking at this, it definitely looks like a kernel panic.

I’ve restarted few times and everytime, it freezes after less than a minute after I’ve logged in. After a quick google search I’ve found this [thread] (https://www.reddit.com/r/SurfaceLinux/comments/5u6iqb/f25_on_surface_pro_3_hangs_completely_including/) that says it is a wifi issue driver.

Did anyone experienced this behavior? if yes, I have a few ideas how to fix it (I think!), but any additional suggestions are more than welcome!
Thanks a lot and have a great day!
Geoff


#51

Hi all!
I reinstalled the KDE version of Fedora 25 and everything works out the box that’s great!
Thank you
Geoff


#52

Do you experience the issues with the live installation media, or after you have installed it? Linux is nowadays quite battle proven on the Surface Pro 3, so there is something going wrong with your setup.


#53

I got Ubuntu from https://www.ubuntu.com/download/desktop/contribute?version=17.04&architecture=amd64

then burned on a USB using Rufus. The result is that the system stay on loading but the installation doesn’t start


#54

Rufus is a powerful tool, but can be misconfigured. Give it another try with Etcher.


#55

nothing mate… same result… 10 min passed and the screen is still black after I chose to install ubuntu


#56

After a day of frustration trying to install Ubuntu (both versions 16 and 17) (I like Ubuntu because it has the broadest driver availability, etc.), I went with Fedora 26.

Fedora installed perfectly on my Surface Pro 3 (I7, 256), dual boot, etc. Really, a perfect seamless install. The Surface keyboard (surface Pro 3 version) works too.

The only negative I’d add is that the wireless connection seemed, the first day, flaky (would suddenly drop and find no signals). But since that day, all is good and stable.


#57

It is very interesting that the Linux experience varies so much, based on comments in this thread. That would suggest that Microsoft is varying the hardware of the SP3. I have not had serious issues with mine.


#58

i have surface pro 4, and i am facing problem in installing surface packages for updates

[email protected]:~$ sudo apt-get install linux-surface
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package linux-surface


#59

The Tigerite’s PPA is depreciated. Meanwhile the Linux kernel support has improved. Just use the latest Ubuntu version available (17.10 beta at the time of writing this), or try Manjaro.


#60

Hey folks - Just installed Manjaro 17.0.5 on my Surface Pro 3 based on what I read here! It looks pretty promising BUT I am having trouble with the wifi card. I posted details here:

Anybody think they have a handle on the (probably driver) issue/resolution on this one?

Update:
My bad - somehow originally posted the wrong link above. Fixed.