Linx and Lamina 7/8/10" tablet owners thread - drivers included!


#41

Anyway back to the original point of this thread - the tablet!

If anyone wants to use it as a cheap media player for late night youtube/movies etc, one of the essential features that I had on my old pocketpc and tablet was the ability to turn the screen off and keep my movie/music/whatever keep on going in the background.

It’s no longer possible to do this due to the instantgo/connected standby bay trail architecture - not in the normal sense anyway.

However, if you add a simple dword to your registry, it is possible to disable connected standby!

The guide to do so is taken from here ( http://windowsitpro.com/windows-client/disabling-windows-connected-standby ):

  1. Start the registry editor (regedit.exe).
  2. Move to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power
  3. Double-click CsEnabled and set to 0, then click OK. (if it doesn’t exist, create it as a simple 32bit dword)
  4. Reboot

This will enable you to use various tools that let you turn off the screen (there are like 4 or 5 on the internet, I use ScreenOff 2 => http://www.thewindowsclub.com/screenoff-turn-off-windows-laptop-screen ) and still keep your mediaplayer playing video/music and all background applications working. The screen itself is really powered down, except for the touch component - so to get your screen powered on, a simple tap will do.

Do note that some programs (like MPC-HC, as documented here=> " https://trac.mpc-hc.org/ticket/5206 ") will still send a “do not turn off the screen” request to the system and they will essentially wake the screen up. Windows Media Player however doesn’t do this and thus can be used nicely.

Another note is, that you lose any kind of “sleep” mode on the device, meaning you can use only hibernate (and of course regular shutdown/reboot). Personally I find hibernate to be my favourite anyway, and if you don’t like it, you can just use fast startup (which is enabled unless you disable hibernate and get rid of the hiberfil.sys file where the speedup “pre-loaded” kernel would be stored for fast startup).

TL;DR, if you want to disable connected standby, this is how!


#42

BTW, I just noticed that goinf to sleep does not kill the Wifi on my Linx / Lamina 7" anymore. Previously it would always die to a state where it would not easily recover back online. Running a Windows 10 with the HP driver pack. I don’t know what has happened - has Microsoft released a some sort of fix for this?

Any comments from other owners? This is a big deal for me as it made the tabled very annoying to use.


#43

I’ve never had problems with mine, even before I disabled connected standby. It just worked. It is worth noting though that I did get my tablet after TH2 came out so the installed version was TH2 already.

Additionally, check this little thing out=> http://eu.banggood.com/Wholesale-Warehouse-4-Port-Micro-USB-OTG-Charger-HUB-Cable-For-Tablet-Phone-wp-Uk-975460.html

I can confirm that it works with Linx 7, as in, it lets you charge AND use OTG at the same time. And not some wanky kinda trickle charge but a normal proper charge without any issues. It is worth noting that to make it work, you have to first go to the Linx uefi, chipset, south bridge, change otg mode to PCI, and turn off vbus. It then works just fine!

I did notice that the Linx will not pick it up after a reboot, but simply unplug it from Linx and plug it back in and everything will spring back to life. I tested it with a wireless usb mouse module, logitech G15 keyboard and a 8terabyte USB3.0 drive plugged in at the same time. (Obviously you only get usb 2.0 speeds but c’mon, this is awesome!).

I’m ordering a second linx as I will use this one as a 24/7 seedbox :smiley: It draws around 1-3W with the screen off. I’m very impressed.


#44

@Vulpix, what tablet exactly did you buy with Windows 10 preloaded?

The official statement from Linx to the Windows 8 generation products is that not even the upgrade is supported. They have since launched models 810 and 1010, which have Windows 10 but I have no idea whether there are hardware changes too.


#45

I did not word myself properly. I got the standard 8.1 bing just like everyone else - but when I upgraded to W10, it was already the TH2 version (using media creation tool).


#46

Hey all Linx/Lamina owners - could check the other thread regarding Remote Desktop Protocol and try if it works for you?


#48

BTW, is the Linx or Lamina 7 rescue image available online somewhere? Or could any of our dear members package their rescue image and place it online?


#49

I have an untouched image of the whole disk, which part do you need?


#50

Which part? Whatever is needed to go back to the out-of-the-box Windows 8.1 state.


#51

So basically you want the whole disk as there is no “recovery image” per se.

I will check if it works for any lynx or if it complains due to license key(s). I have 3 linx 7’s so I will try to restore the initial w8 backup from one to another and see if that works.

The key is stored in UEFI (SLIC) so I’m hoping this will work. It works when used on the same linx, I used it to go back from some experimenting with linux.

I’ll try this tonight and post back with results; if it works and does not complain about license key, I’ll let you know.


#52

Alright.

Got the clean w8 image (essentially, when restored to a linx 7" and booted from, it’ll get you to the screen where you are prompted to choose your country, language, input settings etc; clean system).

Tried restoring it on the original - no problem. Tried restoring it on my 2nd linx, no problem either. In windows, checked with produkey, the system does grab the SLIC key, so you’re good to go. I’m not saying it totally will work, but it worked for me with 2 different linxes, so I don’t see why it wouldn’t work for you or anyone with a linx 7.

You will need to activate - either internet or by phone; but it worked fine on the 2nd linx where I tried it, so I don’t see why it wouldn’t work for you. There may be some metadata related to my backup setup but don’t worry about that, clonezilla should not complain about it, after all it didn’t have a problem with my other linx.

I still recommend you make a complete backup of everything, preferrably using clonezilla too.

Disclaimer: You will lose everything on your linx if you restore this image. E-ve-ry-thing. (except stuff stored on your sd card that is).

(remove space, just a protection against randombots)

( link removed for now, ask if you need it again! )

I’m hosting these on a 30Mbit seedbox, no upload bandwidth limit so knock yourselves out.

Login as cdrw / linxthings .

md5 checksums:
b6eac7a5c158a54749054565896dfda0 *2016-02-22-19-img-clean-w8-serval.7z (this is the clean image, it unpacks into a folder that clonezilla knows how to load)
b834003cd4381791f9644975a49a4f11 *clonezilla-live-2.4.5-15-i686-pae.iso (this is the clonezilla that works with linx for me)

How to:
@Admin , judging from your posts you probably don’t need a detailed guide or any guide in general, so this is mostly for others, if they need this.

  1. DL the iso and the 7z. Check md5 checksums. Make a bootable usb using whatever you like (I used universal usb installer) with the clonezilla preset, using the iso.
  2. unpack the 7z somewhere, either on the bootable usb or on some other usb disk if you have a hub (which tbh you need)
  3. make sure your linx is charged, boot from the usb (del to bios-> last tab-card in bios -> select the bootable usb, it should be listed). On the clonezilla boot screen, select 1st option and boot into clonezilla.
  4. in clonezilla, device-image mode, expert, point clonezilla to whereever you unpacked the 7z into
  5. select restore disk
  6. select the target destination, should be like 31.3GB mmcblk0(somethingsomething).
  7. if worried select check if image is restorable
  8. restore image, woo! (clonezilla will ask you a few times if you’re really really really really sure. Only press y if you are really really really really sure :stuck_out_tongue:
  9. wait for the restoration to proceed.
  10. wait for clonezilla to finish. It might complain in red or yellow text about something like “omg efi file not found” but you can safely ignore that, it always does that but it boots anyway.
  11. reboot, unplug everything,
  12. ???
  13. profit

If you have any trouble let me know.


#53

Awesome, downloading now. I wasn’t actually aware that you could CloneZilla the whole damn mass storage.

So at 1st boot after restoring the CloneZilla image this will initiate the usual Windows 8.x setup procedure, right?


#54

Correct!

And yeah, clonezilla has been very helpful :slight_smile:


#55

I’ve removed the link for now, seems all those that needed the file had gotten it.

@Admin , were you successful?


#56

@Vulpix Yes, thank you very much!


#57

Hi Everyone

Thanks for a great thread. Could I ask for some help.
I’ve bought a Linx 7 and don’t have the rotation button as others have stated. My camera is 90’ off and small.
The two downloads would they help?

Awaiting an answer

Thanks
John


#58
  • If you do not have the screen rotation button available, you are missing the orientation sensor drivers.
  • Not sure if I’ve seen a 90’-off camera before - I would start by updating the driver.

#59

Create a new empty text file, paste this inside:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ROOT\SENSOR\0000\Device Parameters\kxfusion]
"ACPI\\SMO8500\\1-0"="{CDA4B5F8-53B4-4E7C-8A73-0D69852FBEBA}"
"Orientation"=hex:01,01,00,00,01,01,02

save it as “fixrotation.reg”. (make sure it is saved as .reg and not for example as .reg.txt !) Then just double click it to launch it. It will ask if you wanna add the values to your registry, so say yes.

When done, restart the tablet. It worked for me just fine. (Make sure your kionix sensor drivers from the pack are installed first though)


#60

I have tried to update my Lamina 7 but some thingalways didn´t work. After my last effort with the HP-drivers the orientation was 180 degrees out of order. Tapping the onscreen Keyboard did not respond - imaging where it should have been 180 degrees of and then tapping on "empty spaces on the screen did correspond. Very akward and lots of things wouldn’t work. So I got it back to the W8.1 settings. Now it works, but I really need the possibility to store apps and and programs on another drive than C: which is only possible in windows 10.

There has been so many posts about the update issues regarding the Linx-Lamina 7 so it is confusing to figure out were to start. Would it be possible to get a brief update on how to do the Update including a link to the valid driverpackage? I always have issues with the not “enough memory” message. Even if I clean out everything it still says that it needs additionally 8GB of memory. If I redirect the storage directory to the SD-card it still needs 4GB of internal storage.
I would also like to know if you still have issues with the wireless speed. In one of the last updates for w8.1 there was a Realtec RTL8723BS wireless LAN 802.11n SDIO Network adaptor update.
The “funny” thing is that I bought mine in april 2015 and never had any issues with the wireless. It has always worked flawless even with my Samsung 4S. My Lamina 7 Model is T701BR.SE

Kind regards
LarsN


#61

@LarsN are you updating or performing a fresh install?

With the update you should not need many drivers. The last time I did it only the automatic screen rotation needed fixing by adding a driver and a .reg file patch. See the 1st post. When performing a clean install you obviously need several drivers in order to get a fully working device.

Regarding WLAN - the performance on Linx 7 is very very bad. It is slow, unreliable and may die completely when device goes to sleep mode.